[FASTCGI] Issue on mod fastcgi 2.4.7 and apache 2.2.11 on win32

Octavian RÔsnita orasnita at gmail.com
Tue Feb 24 17:32:31 EST 2009


I want to be able to run a program in perl (made using the Catalyst framework) using fastcgi, but use it like an external daemon - to be able to restart the application without needing to restart Apache.

fcgid doesn't offer this feature but only fastcgi and I wasn't able to install fastcgi under Windows.

Thank you.

Octavian

  ----- Original Message ----- 
  From: antonio cipolletti 
  To: 'Octavian RÔsnita' ; fastcgi-developers at mailman.fastcgi.com 
  Sent: Wednesday, February 25, 2009 12:23 AM
  Subject: RE: [FASTCGI] Issue on mod fastcgi 2.4.7 and apache 2.2.11 on win32


  Hi, i developed a fastcgi win32 exe spanned in 5 process. This system is working from one year ago.

  It is implemented like a normal executable according to fastcgi specification.

  What details do you refer?

   


------------------------------------------------------------------------------

  From: Octavian RÔsnita [mailto:orasnita at gmail.com] 
  Sent: martedý 24 febbraio 2009 14.53
  To: antonio cipolletti; fastcgi-developers at mailman.fastcgi.com
  Subject: Re: [FASTCGI] Issue on mod fastcgi 2.4.7 and apache 2.2.11 on win32

   

  Hi,

   

  Are there somewhere details about how to make fastcgi work on Win32?

   

  Can fastcgi run an external program under Win32?

   

  Thanks.

   

  Octavian

    ----- Original Message ----- 

    From: antonio cipolletti 

    To: fastcgi-developers at mailman.fastcgi.com 

    Sent: Tuesday, February 24, 2009 2:50 PM

    Subject: [FASTCGI] Issue on mod fastcgi 2.4.7 and apache 2.2.11 on win32

     

    HI, my fastcgi application is working fine on win32 apache 2.2.8.

    I must migrate to apache 2.2.11 win32, I know there is an incompabtibility with the new apr 1.3.3, so i rebuild the mod fastcgi snapshot mod_fastcgi-SNAP-0811090952,

    and I recompiled my application with the new library required for 2.2.11 and mod_fastcgi-SNAP-0811090952.

     

    When I try to start apache there are following erros

     

    [Tue Feb 24 13:41:04 2009] [crit] (OS 123)The filename, directory name, or volume label syntax is incorrect.  : FastCGI: can't exec server "C:/tlx/MTF/FCGI/FCGI/ReqHandler/ReqHandler/req/Release/req.exe", CreateNamedPipe() failed

    [Tue Feb 24 13:41:04 2009] [crit] (OS 123)The filename, directory name, or volume label syntax is incorrect.  : FastCGI: can't start server "C:/tlx/MTF/FCGI/FCGI/ReqHandler/ReqHandler/req/Release/req.exe": spawn_fs_process() failed

     

    the directive on http.conf is following

    FastCgiServer C:/tlx/MTF/FCGI/FCGI/ReqHandler/ReqHandler/req/Release/req.exe -processes 2 

     

    Anyone can help me to understand the problem ?

     

    Many Thanks in advance.

     

    Antonio Cipolletti

     


----------------------------------------------------------------------------

    _______________________________________________
    FastCGI-developers mailing list
    FastCGI-developers at mailman.fastcgi.com
    http://mailman.pins.net/mailman/listinfo.cgi/fastcgi-developers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.pins.net/mailman/private.cgi/fastcgi-developers/attachments/20090225/d75faca5/attachment-0001.html>


More information about the FastCGI-developers mailing list