[FASTCGI] HTTP Status Code problem

Howard May Howard.May at dialogic.com
Fri Jan 22 11:38:35 EST 2010


I'm pretty sure it's not a server configuration problem as when I add

FCGX_FPrintF(request.out, "Status: 200 OK\r\n

As you suggested it works fine!

I had presumed that Abyss would handle the HTTP header for me.

Thanks for your help

Regards 

> -----Original Message-----
> From: fastcgi-developers-
> bounces+howard.may=dialogic.com at mailman.fastcgi.com [mailto:fastcgi-
> developers-bounces+howard.may=dialogic.com at mailman.fastcgi.com] On Behalf
> Of Aron Szabo
> Sent: 22 January 2010 16:34
> To: fastcgi-developers at mailman.fastcgi.com
> Subject: Re: [FASTCGI] HTTP Status Code problem
> 
> Hi!
> 
> You get 404 and your XML packet is transferred ? Are you sure that your
> application receives the request? How do you connect your app with the
> webserver ?
> 
> Header sould be sent out like this:
> FCGX_FPrintF(request.out, "Status: 200 OK\r\nContent-Type:
> application/xml\r\n\r\n");
> 
> But I think you have a server configuration problem...
> 
> Aron Szabo
> Pointless Software
> http://pointless.hu
> 
> On 01/22/2010 03:50 PM, Howard May wrote:
> > Hi,
> >
> > My fastCGI App is serving up small XML packets with MIME type
> application/xml. The problem is that my client is reporting an HTTP Status
> of 404 which I presume is being added by my Web Server (Abyss). Is there
> something I need to be doing in my fastCGI app to prevent this?
> >
> > Best Regards
> >
> >
> >
> >
> > _______________________________________________
> > FastCGI-developers mailing list
> > FastCGI-developers at mailman.fastcgi.com
> > http://mailman.pins.net/mailman/listinfo.cgi/fastcgi-developers



More information about the FastCGI-developers mailing list