[FASTCGI] FastCGI requests timing out prematurely

Gordon gordon at group309.com
Wed Mar 3 15:53:56 EST 2010


I neglected to include some potentially useful information:

 

I'm using Apache httpd 2.2.3 on Red Hat Enterprise Linux and
mod_fastcgi-2.4.6.

 

Regards,

Gordon

 

 

 

  _____  

From: fastcgi-developers-bounces+gordon=group309.com at mailman.fastcgi.com
[mailto:fastcgi-developers-bounces+gordon=group309.com at mailman.fastcgi.com]
On Behalf Of Gordon
Sent: Wednesday, March 03, 2010 10:34 AM
To: fastcgi-developers at mailman.fastcgi.com
Subject: [FASTCGI] FastCGI requests timing out prematurely

 

I am using a static fastcgi server with mod_fastcgi and an apache web
server, and my requests are timing out prematurely. My idle-timeout is set
to 30 seconds. For some reason, requests are being timed out after only
about 11 seconds (I measured this at the http client, from the time the
request was submitted until the time that apache responded with an error).
When this happens, I get the following message in the apache log:

 

[Wed Mar 03 10:06:35 2010] [error] [client 10.28.98.252] FastCGI: comm with
server "/var/www/fcgi-bin/myserver2" aborted: idle timeout (30 sec)

 

I tried setting idle_timeout to 60 seconds but doing so had no affect;
requests still timed out after approximately 11 seconds.

 

Here is my fastCgiServer directive from my httpd.conf file:

 

FastCgiServer /var/www/fcgi-bin/myserver2 -initial-env
'CONFIG_FILENAME=/var/myserver2/config/config.properties' -idle-timeout 30
-processes 20 -flush

 

Has anyone else seen this behavior? Any ideas how to fix it?

 

Thanks,

Gordon

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.pins.net/mailman/private.cgi/fastcgi-developers/attachments/20100303/984efefb/attachment.html>


More information about the FastCGI-developers mailing list