improved mod_fastcgi for Apache now available

Mark Brown (mbrown@OpenMarket.com)
Tue, 04 Jun 1996 16:41:57 -0400

Message-Id: <199606042041.QAA12234@breckenridge.openmarket.com>
To: fastcgi-developers@OpenMarket.com
Subject: improved mod_fastcgi for Apache now available
Date: Tue, 04 Jun 1996 16:41:57 -0400
From: Mark Brown <mbrown@OpenMarket.com>


An improved mod_fastcgi for Apache is now available.  The new version
fixes all the reported problems with the previous version of the module:

    It works with Apache 1.0.x and with 1.1.  (This requires editing a
    version string in the module; I'd be happy to fold in a patch
    that autoconfigures this version string, if somebody can
    test and then send such a patch to me.)

    It isolates the dependency on FILE * internals to a single function
    ("tell me the number of bytes buffered by this FILE *"),
    making ports to Linux and other systems easier.  (I'd be happy
    to fold in a patch to make it work on Linux with no hand editing, if
    some Linux user will test and then send the patch to me.)
    The FILE * internals issue is a non-issue with Apache 1.1.

    It sets the socket permissions correctly when the server parent
    is running as root and the children are running as some less
    privileged user.

Thanks to everyone who reported problems and sent in patches.

    --mark