Re: run-time problems

Nigel Metheringham (
Thu, 27 Jun 1996 09:27:12 +0100

Message-Id: <>
To: Robert Spearman <>
From: Nigel Metheringham <>
Subject: Re: run-time problems 
In-Reply-To: Your message of "Wed, 26 Jun 1996 14:58:42 PDT."
Date: Thu, 27 Jun 1996 09:27:12 +0100

} I have tried to complie fastCGI on Linux, using Apache 1.1b3 and perl 
} 5.002, and everything appears to have compiled without any problems. 

Did you actually recompile perl with fastcgi, and install at least 
perl and the fastcgi module
[slight digression... I didn't wish to risk breaking a working perl 
setup, so I did the perl with fastcgi build as usual, ran the self 
tests, then installed the new perl binary as fperl, and installed the 
fcgi module, which consists of and 2 or 3 other files 
(including a loadable object file - assuming you have dynamically 
loadable modules).
To find what needs installing, you can run the perl install script 
with a -n option which tells you what it is going to do.  ]

} If I run the program from the command line I get a:
} "Can't locate in @INC at xxx.fcgi line 16.
} BEGIN failed--compilation aborted at xxx.fcgi line 16."
} [this is just the simple counter example program]
} (manually copying this file into a perl library directory gives an error 
} about not being able to load parts of the module or something like that)

rather more is needed...

[   - Unix Applications Engineer ]
[ *Views expressed here are personal and not supported by PLAnet* ]
[ PLAnet Online : The White House          Tel : +44 113 251 6012 ]
[ Melbourne Street, Leeds LS2 7PS UK.      Fax : +44 113 2345656  ]