Perl 5.003 support?

Robert S. Muhlestein (robertm@teleport.com)
Wed, 10 Jul 1996 14:59:35 -0700 (PDT)

Date: Wed, 10 Jul 1996 14:59:35 -0700 (PDT)
From: "Robert S. Muhlestein" <robertm@teleport.com>
To: fastcgi-developers@openmarket.com
Subject: Perl 5.003 support?
Message-Id: <Pine.SUN.3.92.960710134900.12193Q-100000@zoe.teleport.com>

Just got on the list.  Forgive my haste, but I have noticed that the
developer's kit contains instructions and docs for Perl5.002.  From the
CHANGES file in the Perl5.003 release, which mostly fixes bugs in Perl5.002,
I noticed that there were a few significant changes to perl.c.  According to
the docs with the kit, this file is to be replaced with the one provided
from the kit (along with a few others).

My hunch is that this will not fly (although I have not tried it) because
the perl.c and other files that came with the kit will not reflect the
changes made in Perl5.003.  I am using Perl5.002 to make the build without
much difficulty.  Just thought I'd see what the status was on the move to
support Perl5.003.

It seems very odd to me that using the perl interpreter under FCGI requires
changes to the interpreter source files and a recompile.  Wouldn't a better
approach be to make the FCGI.pm module a stand alone?  Then instead of
recompiling, I'd do something like:

#!/usr/local/bin/perl

use lib qw( . /path/to/the/FCGI.pm );
use FCGI;

This will solve the problem with keeping up with perl versions (ie. 5.003).

Robert Muhlestein
Teleport Creative Services
CGI/Java Guy
cgi@teleport.com