Re: Perl 5.003 + FastCGI

Steve Kann (stevek@io360.com)
Thu, 8 Aug 1996 08:59:59 -0400 (EDT)

From: Steve Kann <stevek@io360.com>
Message-Id: <199608081259.IAA16205@spheara.io360.com>
Subject: Re: Perl 5.003 + FastCGI
In-Reply-To: <31FE9252.167EB0E7@ind70.industry.net>
To: fastcgi-developers@openmarket.com
Date: Thu, 8 Aug 1996 08:59:59 -0400 (EDT)

I normally don't give up so easily, but I've already tried doing this
several times using different "recipes", and I still am not able to do
this sucessfully.

I'm trying to build a fastcgi-stdio enabled perl 5.003001 interpreter on
Solaris 2.5.

I tried following the directions given in the thread beginning at
<A href="http://www.fastcgi.com/mail-archive/0133.html">
http://www.fastcgi.com/mail-archive/0133.html</a>.

I think that they were missing something, though (besides the need to
copy in the FCGI extension), because although I got a perl that passed
all the tests, it didn't work properly for fastcgi applications.

( A truss showed that although it was speaking the protocol correctly,
it was not sending anything in the stdout stream).

So, I tried again, several times using several different methods.  The
last attempt came from this procedure:

1) Start from a fresh Perl5.003001 distribution.

2) copy the FCGI extension into place.

3) Run Configure.  Don't do anything special for fastcgi (because the
test programs won't work if you do).

4) At the end, when prompted to edit config.sh, do so.  Make all the
edits suggested in the Advanced recipe.  

5) build and test.

Unfortunately, aside from my first attempt (which I think didn't fully
integrate the fcgi-stdio into perl), all of these attempts which
I think have truly integrated the fcgi-stdio, have failed on the
lib/io_xs test.

here's the output:
root@spheara:/opt/perl/v5.003/src/t # ./perl lib/io_xs.t 
1..2
not ok 1
Can't use an undefined value as a symbol reference at lib/io_xs.t line
21.

And here's the relavent code from io_xs.t:
     14 use IO::File;
     15 use IO::Seekable;
     16
     17 print "1..2\n";
     18 use IO::File;
     19 $x = new_tmpfile IO::File or print "not ";
     20 print "ok 1\n";
     21 print $x "ok 2\n";
     22 $x->seek(0,SEEK_SET);
     23 print <$x>;

Anyone else have similar problems?  Any ideas?  I'm really out of them,
and also since I'm building on a stock SS10, the build process is rather
slow for perl,  so these attempts have taken two days already..

Thanks alot!

-SteveK