Re: FCGI & problems

Rujith S. de Silva (
Fri, 09 Aug 1996 12:06:22 -0400

Message-Id: <>
Date: Fri, 09 Aug 1996 12:06:22 -0400
From: "Rujith S. de Silva" <>
Subject: Re: FCGI & problems

bpm wrote:
> Well, I've got perl5.003, FCGI dev kit 1.5 configured and running on a
> sparc solaris 2.4 (sorry don't have 2.5 :-) ) & all seems to work just
> great BUT
> The package breaks when I make it with the fcgi includes.  I'm
> not that great of a 'c' hacker to know why, but if I make the
> package with the CCFLAGS as:

I managed to get perl5.003, fcgi 1.5, gd 1.2 and 1.00 working on
Solaris 2.5.  BPM: Did you recompile gd 1.2 with FCGI?  To do so, I
edited the gd makefile as follows:

CFLAGS=-I/usr/local/omhttpd/fcgi-devel-kit/include -include \
	/usr/local/omhttpd/fcgi-devel-kit/include/fcgi_stdio.h -O
LIBS=-L/usr/local/omhttpd/fcgi-devel-kit/libfcgi -L/usr/local/lib \
	-L/opt/local/lib -L/opt/gnu/lib -L./ \
	-lfcgi -lsocket -lnsl -lgd -lm -lc

This compiled fine on my system, and the demo worked, generating

I then linked libgd.a to /usr/local/lib/, and gd.h to

Then GD 1.00 compiled out of the box, and its demos (, etc.)
worked fine.

I guess this is another confirmation that the fcgi trick of re-defining
stdio (which I still dislike to some extent) does work for integrating
with third-party applications when source is available.  I haven't tried
doing any integrations when source is not available.