Java, FastCGI and Apache (aka "Help me, Steve Harris")

Zaki Alam (zaki@sirrus.com.inter.net)
Wed, 14 Aug 1996 20:14:37 -0700

Message-Id: <3212961D.167E@sirrus.com>
Date: Wed, 14 Aug 1996 20:14:37 -0700
From: Zaki Alam <zaki@sirrus.com.inter.net>
To: fastcgi-developers@openmarket.com
Subject: Java, FastCGI and Apache (aka "Help me, Steve Harris")

Well, I read the previous threads in the archived mail and I still can't
get my Java FastCGI apps to run correctly.

This is what I'm doing:

1) didn't change srm.conf
2) ran the java app via 
	"exec /usr/local/bin/java -DFCGI_PORT=10001 TinyFGCI"
3) installed a script called test.cgi into the cgi-bin directory with
the contents:

	#!./cgi-fcgi -f
	cgi-fcgi -bind -connect zeus:10001

where zeus is the hostname of the machine where everything is running.



Okay, here are the problems/symptoms:

1) loading the script from the browser gives me an server internal
   error.
2) if I run 'cgi-fcgi -bind -connect zeus:10001', the applet will give 		
   me one session's output then bomb out.
3) running the test.cgi script from the command line is giving me a
   SegFault. 
4) during the compile of the cgi-fcgi program, there are warnings.


Solutions?
1) If the srm.conf file needs changing (and the cgi-fcgi program needs
to be in the fcgi-bin dir) does someone have an example?

2) If it looks like a problem with cgi-fcgi, can someone point me to an
IRIX 5.3 version?


Thanks for help, anyone ... I really appreciate it. Sorry I couldn't
figure it out from the threads and had to pretty much repost.

Zaki Alam
zaki@sirrus.com