Linux/fastCGI - AppClass not working

Wes Sonnenreich (sonny@ECF-4.MIT.EDU)
Sun, 08 Dec 1996 01:59:56 -0500

Message-Id: <32AA676C.8B0@gsd.mit.edu>
Date: Sun, 08 Dec 1996 01:59:56 -0500
From: Wes Sonnenreich <sonny@ECF-4.MIT.EDU>
To: fastcgi-developers@openmarket.com
Subject: Linux/fastCGI - AppClass not working

The problem:

the AppClass directive does nothing, thus no process is started and fcgi
doesn't work. 

What I've done:

I've built fcgi into Apache 1.2b1(using what it comes with) AND 1.1.1
(using fastcgi_mod.v14)

I've used tiny-fcgi with cgi-fcgi from the command line -- works fine.

I've set up apache with the minimal config to run the tiny prog. using
the included httpd.conf (made all of the necessary $FCGI/$APACHE
changes)

I've placed these files in every directory imaginable (trying to work
around potential ScriptAlias conflicts, even turned ScriptAlias off)

When I run a test fcgi prog in Perl-5 (built that in too) through
apache, it runs, but the process isn't persistant.. just acts like a
normal cgi script.

When I run tiny-perl-fcgi using cgi-fcgi, the process finishes
immediately, instead of staying open. (but it works with the compiled C
version)

---------------

I think I have 2 problems here... one is w/apache and fcgi, the other is
with perl and fcgi.

I'm running linux (can't remember which release) gcc2.7.? on a 
cyrix/pentium box. 

Any help would be greatly appreciated... i've tried every suggestion I
could find in the archives (many made it possible to get this far!)

Wes Sonnenreich