New FastCGI Developers Kit (1.5.1)

Stanley Gambarin (gambarin@openmarket.com)
Thu, 12 Dec 1996 14:50:25 -0500

Message-Id: <199612121950.OAA13791@u4-138.openmarket.com>
To: fastcgi-developers@openmarket.com
Subject: New FastCGI Developers Kit (1.5.1)
Date: Thu, 12 Dec 1996 14:50:25 -0500
From: Stanley Gambarin <gambarin@openmarket.com>

	The new version of the FastCGI Developers Kit (1.5.1) is  currently
on the http://www.fastcgi.com/applibs/fcgi-devel-kit.tar.Z  This is a 
minor release, with the following functionality:
	1. Couple of conditional compiles for HP-UX.
	2. Cast around FCGI_Header to eliminate assertion failures
		ASSERT(sizeof(FCGI_Header) == FCGI_HEADER_LEN);
	3. Loop around accept() call to eliminate the 
		OS Error: Interrupted System Call.

	*** Important Note:
	- The kit has been compiled under Solaris 2.5 without a problem,
	however, I had not had a chance to compile and test it under 
	other platforms.  I would appreciate any possible bugs and/or
	fixes for the above kit.
	- The index on the website should be updated within the next 
	day to reflect proper version of FDK.  In the meantime, you 
	must use full URL which was specified above.

						Thanks, Stanley.
-- 

*******************************************************************************
* Stanley Gambarin			Open Market Inc.		      *
* FastCGI (soon-to-be) Guru		245 First St. Cambridge MA 02142      *
*					(617) - 949 - 7487		      *
* mailto:gambarin@openmarket.com					      *
* 				http://acs2.bu.edu:8001/~stanleyg (school)    *
*				mailto:stanleyg@cs.bu.edu		      *
*******************************************************************************