FastCGI and SSI

Yalcin Bozcaada (bozcaada@OpenMarket.com)
Mon, 30 Dec 1996 12:26:13 -0500

Message-Id: <1.5.4.32.19961230172613.0090a890@mail-60.openmarket.com>
Date: Mon, 30 Dec 1996 12:26:13 -0500
To: fastcgi-developers@OpenMarket.com
From: Yalcin Bozcaada <bozcaada@OpenMarket.com>
Subject: FastCGI and SSI

For people who want to use SSI with their new or converted FastCGI programs:

Currently Open Market's SWS 2.0.5 does not support SSI using FastCGI.
Neither do any other server as far as I know. 

Yet, there is a solution for that too: cgi-fgci tool.

All you have to do is call the CGI application that runs cgi-fcgi and
connects to FastCGI program and runs it. Accroding to documentation this was
provided for other servers which cannot run AppClasses. This will run slower
than an AppClass but will be a boost for converted CGI programs, especially
the ones that take a long time for initializations. For help on using
cgi-fcgi please refer to:
http://www.fastcgi.com/kit/doc/fcgi-devel-kit.htm#S4.2



*----------------------------------------------------------------*
*- yalcin Bozcaada						-*
*- Open Market Inc. "The Internet Commerce Company"		-*
*- 245 First Street, Cambridge, MA 02142  USA			-*
*- www.openmarket.com						-*
*- Phone: +1 617 949 7543 					-*
*----------------------------------------------------------------*