[fwd] FastCgi and Apache 1.1 ..........

Stanley Gambarin (gambarin@OpenMarket.com)
Thu, 02 Jan 1997 12:23:43 -0500

Message-Id: <199701021723.MAA07674@u4-138.openmarket.com>
To: fastcgi-developers@OpenMarket.com
Date: Thu, 02 Jan 1997 12:23:43 -0500
From: Stanley Gambarin <gambarin@OpenMarket.com>
Subject: [fwd] FastCgi and Apache 1.1 ..........


- ----- Forwarded message from Earl J. Baudin -----

>From shellus.com!baudin@vogon.muc.de  Mon Dec 23 19:17:16 1996
Subject: FastCgi and Apache 1.1 ..........
Date: Mon, 23 Dec 1996 15:13:39 +0100
From: "Earl J. Baudin" <baudin@shellus.com>

Ralf,

Not sure if you are the right person for this, but your email address is
the only one I could find associated with FastCgi and Apache.  I grabbed
fastcgi and Apache 1.1 off the net the other day and have been playing
around with it for a few days.  I came across a weird problem that you
might be able to help me with.

My setup:

   Server: SunOS 5.5 sun4m sparc SUNW,SPARCstation-20
  FastCgi: Version 1.4 for Perl
     Perl: Version 5.002 binary with FastCgi built in

I setup the server and tried testing the echo-perl example provided on the
fastcgi web page.  It worked, BUT an extra copy of the program (echo-perl)
was being started and parent owned by init.  I played with script and
found that it seems to be a timing problem.  If I put a sleep or 4 comment
lines at the top of echo-perl, the extra version is not started (or dies
before I can do a ps).  Has anyone else reported this problem?

Thanks!

Earl Baudin

           Shell Oil Company, Westhollow Technology Center
    3333 Hwy 6 South, Houston, TX, 77082     Voice: (281)544-6785
                    Internet: baudin@shellus.com

------- End of Forwarded Message