FastCGI, NCSA 1.5.2 & SSI

Scott Franzyshen (saf@bigsurf.net)
Sun, 19 Jan 1997 14:38:36 -0500

Message-Id: <32E2783C.2AAA@bigsurf.net>
Date: Sun, 19 Jan 1997 14:38:36 -0500
From: Scott Franzyshen <saf@bigsurf.net>
To: fastcgi-developers@OpenMarket.com
Subject: FastCGI, NCSA 1.5.2 & SSI

I have succesfully installed the fcgi-devel-kit, Made perl5.003, and installed
NCSA 1.5.2 HTTPD server. I have created a FCGI perl script to lookup values
from a mSQL server. All of the above works fine, except I would like to be able to
use this as a SSI(server side include). However when I attempt to use it with either
the "exec cmd" or the "exec cgi" I get the following responce in the page,

[an error occurred while processing this directive]

I have even attempted to use the "include" and "include virtual" with the same result.

while I understand that I could use the cgi-fgci tool to wrap the fcgi, this would 
defeat the purpose of using FCGI in the first place(to reduce time loading, processing, 
and unloading.) the standard perl cgi script could be converted into a C version
and reduce overhead of loading and unloading the perl interpreter.
any assistance would be helpful. 

Scott Franzyshen
saf@bigsurf.net