Apache 1.2b6, Oracle7, and FastCGI 1.4.3

Noah M. Couture (noah@myriadagency.com)
Wed, 12 Feb 1997 10:22:29 -0500 (EST)

Date: Wed, 12 Feb 1997 10:22:29 -0500 (EST)
From: "Noah M. Couture" <noah@myriadagency.com>
To: fastcgi-developers@OpenMarket.com
Subject: Apache 1.2b6, Oracle7, and FastCGI 1.4.3
Message-Id: <Pine.GSO.3.95.970212100945.16201L-100000@geyser.myriadagency.com>

Hello,
  
  Does anybody out there have any experience using the above combination?
I have not been very successful in implementing this. Id like to use FastCGI,
since it sucks to connect and disconnect from the database for every cgi
script.

Heres the problem. Im writing a C (Pro*C) web application. It is compiled
with Oracle shared libraries. In order for the operating system
(Solaris 2.5.1, btw) to load the executable, it needs to find the Oracle
libraries. In order for this to happen, the LD_LIBRARY_PATH environment
variable must include their path. There are also a couple of other environment
vars that Oracle likes. Heres what I tried:

AppClass /disk/columbia/website/www/browse.fcgi -initial-env ORACLE_HOME=/ora01/
app/oracle/product/7.3.2 -initial-env LD_LIBRARY_PATH=/ora01/app/oracle/product/
7.3.2/lib -initial-env ORACLE_SID=jrc

I also have the <Location> stuff to set the handler.

However, it did not work. I still get this:

ld.so.1: browse-autos.cgi: fatal: libclntsh.so.1.0: can't open file: errno=2