Sfio+perl=problem (Linux)

=?iso-8859-2?Q?Micha=B3?= Mosiewicz (mimo@lodz.pdi.net)
Wed, 26 Mar 1997 13:48:18 +0100

Message-Id: <33391B12.5BF9DCEC@lodz.pdi.net>
Date: Wed, 26 Mar 1997 13:48:18 +0100
From: =?iso-8859-2?Q?Micha=B3?= Mosiewicz <mimo@lodz.pdi.net>
To: fastcgi developers <fastcgi-developers@OpenMarket.com>
Subject: Sfio+perl=problem (Linux)

Hello,

Got a problem with sfio. It compiles fine, perl compiles fine, but...

I've noticed several problems with socket communication. My own
procedures as well as modules from libnet (Net::FTP) and libwww denied
to work. The problems is with opening tcp sockets.

I recompiled perl with and without sfio. I then compared the results of
'make test' in perl. The only difference was that with sfio perl fails
on test lib/io_sel (test #11). i.e. perl stops on checking if
$sel->can_write.

Also I run tests in sfio. Everything was OK but the mmap test which
wouldn't compile because of wrong mmap declaration.

Has anybody experienced such problems? My system is Linux 2.0.29 (libc
5.4.17), I tried perl5.003_90,93,94 and got the same results each time.
Each time I compiled perl from scratch to avoid some interferences.

Mike


-- 
********     MEMBER OF THE INTERNATIONAL PROGRAMMERS GUILD    ********
WWW: http://www.lodz.pdi.net/~mimo  tel: Int. Acc. Code + 48 42 148340
add: Michal Mosiewicz  *  Bugaj 66 m.54 *  95-200 Pabianice  *  POLAND