problems with FCGI.pm

Raul Gonzalez Barron (barron@EESUN2.tamu.edu)
Fri, 9 May 1997 12:00:23 -0500 (CDT)

Date: Fri, 9 May 1997 12:00:23 -0500 (CDT)
From: Raul Gonzalez Barron <barron@EESUN2.tamu.edu>
To: fastcgi-developers@OpenMarket.com
Subject: problems with FCGI.pm
In-Reply-To: <337214D6.446B9B3D@hayburn.com>
Message-Id: <Pine.SOL.3.95.970509115239.8950A-100000@eesun1.tamu.edu>

Hello!

I finally got sfio and Perl recompiled with the sfio support. I am now
trying to test this simple fcgi application for the first time:

----------
#!/usr/local/bin/perl
use FCGI;
$count = 0;
while(FCGI::accept() >= 0) {
    print("Content-type: text/html\r\n\r\n",
          "<title>FastCGI Hello! (Perl)</title>\n",
          "<h1>FastCGI Hello! (Perl)</h1>\n",
          "Request number ", $++count,
          " running on host <i>$ENV('SERVER_NAME')</i>");
}
----------

but I am getting the following message:

------------
Can't find loadable object for module FCGI in @INC
(/export/home/barron/fcgi-devel-kit/perl-5/common/ext/FCGI
/usr/local/lib/perl5/sun4-solaris/5.003 /usr/local/lib/perl5
/usr/local/lib/perl5/site_perl/sun4-solaris /usr/local/lib/perl5/site_perl
.) at /export/home/barron/fcgi-devel-kit/perl-5/common/ext/FCGI/FCGI.pm
line 13
BEGIN failed--compilation aborted at test.fcgi line 2.
-------------
apparently the system can't find FCGI.pm, even though I used the "set env
PERL5LIB /export...." to specify the location of FCGI.pm

Has anyone run into this problem, any ideas/suggestions??

Thanks for your time,

-Raul