Re: Apache 1.2 & FastCGI

Ian Bond (ianb@cursci.co.uk)
Tue, 10 Jun 1997 11:30:24 +0100

Message-Id: <339D2CC0.2089@cursci.co.uk>
Date: Tue, 10 Jun 1997 11:30:24 +0100
From: Ian Bond <ianb@cursci.co.uk>
To: fastcgi-developers@OpenMarket.com
Subject: Re: Apache 1.2 & FastCGI

Sorry to bother you with a compilation problem, but fastCGI carries our
website.

On Sparc Solaris 2.5.1 trying a build of Apache 1.2.0 with mod_fastcgi
version 1.4.3, results in the following error :

Done building module subdirectories
gcc -c -Iregex  -O2 -DSOLARIS2 -DSTATUS   mod_fastcgi.c
mod_fastcgi.c:701: redefinition of `Sigfunc'
conf.h:639: `Sigfunc' previously declared here
*** Error code 1
make: Fatal error: Command failed for target `mod_fastcgi.o'

Apache 1.2b8 with mod_fastcgi version 1.4.3 worked with the same
configuration. Has anyone else tried Apache 1.2.0 & FastCGI ?

cheers Ian



Sonya Rikhtverchik wrote:
> 
> Hi Ian
> Well, it's next on my list :)
> I am about to try it with 1.2.
> I will let you know if I can get it to work.
> Also, you might want to send your question to the list, I am sure somebody out
> there has already tried it. (Don't forget to mention your platform, etc.)
> 
> Sonya