FCGI 0.30 make fails w/ Perl 5.004_01 + linux

Stuart Stock (stuart@gundaker.com)
Thu, 10 Jul 1997 22:50:47 -0500 (CDT)

Date: Thu, 10 Jul 1997 22:50:47 -0500 (CDT)
From: Stuart Stock <stuart@gundaker.com>
To: FastCGI Developers <fastcgi-developers@OpenMarket.com>
Subject: FCGI 0.30 make fails w/ Perl 5.004_01 + linux
Message-Id: <Pine.LNX.3.95.970710224516.15645A-100000@mona.gundaker.com>


  I'm trying to build FCGI on a Linux 2.0.30 box with sfio enabled Perl
5.004_01 and am getting the following errors on a make:

# perl Makefile.PL
 .. runs fine ..

# make
/usr/bin/perl -I/usr/lib/perl5/i586-linux/5.00401 -I/usr/lib/perl5
/usr/lib/perl5/ExtUtils/xsubpp -typemap /usr/lib/perl5/ExtUtils/typemap
/FCGI.xs >FCGI.tc && mv FCGI.tc FCGI.c
Please specify prototyping behavior for FCGI.xs (see perlxs manual)

cc -c -I. -Dbool=char -DHAS_BOOL -I/usr/local/include
-I/arc/perl/sfio/include -O2 -DVERSION=\"0.30\" -DXS_VERSION=\"0.30\" -fpic
-I/usr/lib/perl5/i586-linux/5.00401/CORE FCGI.c
In file included from /usr/lib/perl5/i586-linux/5.00401/CORE/perl.h:1910,
                 from FCGI.xs:2:
/usr/lib/perl5/i586-linux/5.00401/CORE/proto.h:58: unrecognized format
/specifier for `'

make: *** [FCGI.o] Error 1

  On a BSDI 2.1 box, I get the "specify prototyping behavior" but it still
compiles.  Any help would be appreciated.

stuart

--
Stuart Stock                                   stuart@gundaker.com