Fastcgi "OS error: interrupted system call" still happens

Sonya Rikhtverchik (rikhtver@OpenMarket.com)
Thu, 24 Jul 1997 10:24:11 -0400

Message-Id: <199707241424.KAA00337@u4-138.openmarket.com>
To: fastcgi-developers@OpenMarket.com
Subject: Fastcgi "OS error: interrupted system call" still happens
Date: Thu, 24 Jul 1997 10:24:11 -0400
From: Sonya Rikhtverchik <rikhtver@OpenMarket.com>


Message-Id: <19970723151719.13361@clari.net>
Date: Wed, 23 Jul 1997 15:17:19 -0700
From: Brad Templeton <brad@clari.net>
To: fastcgi-developers@openmarket.com
Subject: Fastcgi "OS error: interrupted system call" still happens
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
X-Mailer: Mutt 0.61.1
Organization: ClariNet Communications Corp.  http://www.clari.net/brad

I'm using Fastcgi to support the page bn.newspage.com, but about once
a day we will see this error start on the server and it doesn't go
away untill you kick it.   I have a daemon watch the logs and kick the
web server if it sees the error -- sigh.

The cgi was compiled with version 1.5.1 of the library of Dec 12 96,
and it has the loop around the accept call described in earlier messages
on this list as a fix to this problem, but it still shows up.

The "OS error: connection refused" error also was showing up until I
bumped the listen-queue-depth up to a high number.

Running apache 1.2.0 but not the new beta mod_fcgi which was not reliable
enough for this.

It's hard to test for as it seems to be something that only shows up
under load, though there have been times when it slowed up
immediately.

Any thoughts?  

------- End of Forwarded Message