Re: symbol not found: _sfdisc

Alan Rykhus (alan.rykhus@mankato.msus.edu)
Tue, 9 Sep 1997 10:48:58 -0500 (Central Daylight Time)

From: Alan Rykhus <alan.rykhus@mankato.msus.edu>
To: Sven Verdoolaege <skimo@breughel.ufsia.ac.be>
Subject: Re: symbol not found: _sfdisc
In-Reply-To: <19970909122828.61350@breughel.ufsia.ac.be>
Message-Id: <SIMEON.9709091058.E@AL.mail.mankato.msus.edu>
Date: Tue, 9 Sep 1997 10:48:58 -0500 (Central Daylight Time)


On Tue, 9 Sep 1997 12:28:28 +0200 Sven Verdoolaege 
<skimo@breughel.ufsia.ac.be> wrote:

> On Mon, Sep 08, 1997 at 06:43:26PM -0400, David J. MacKenzie wrote:
> > On Mon, 8 Sep 1997 12:32:40 -0500 (Central Daylight Time), Alan 
> > Rykhus <alan.rykhus@mankato.msus.edu> said:
> > > I'm still working on getting the Perl FCGI module to work on 
> > > UnixWare. By putting some debugging code into Apache I discovered 
> > > the buffer that is passed from the fascgi script to Apache 
> > > contains "dynamic linker: /usr/bin/perl: symbol not found: 
> > > _sfdisc"
> 
> You didn't say what version of FCGI and sfio you're using.
> I don't have much time now; might look into other stuff next week.

I'm using version 0.31 of FCGI and sfio97, also perl5.004_01

> > 
> > That's supposed to be resolved from the sfio libsfdisc.  Did you
> > install that?  It's a static library on my BSDI box, but maybe on
> > UnixWare it's compiled shared.
> 
> It probably is a static library. Try linking it in the FCGI module
> itself.

I built the libsfdisc, linked it into perl, same results.
I then added libsfdisc to the makefile and linked it in as I built the 
FCGI module, same results.

I've noticed in the code that whenever _sfdisc is defined there are 
comments about removing things on the next release. Do you know if 
there is a special reason for these comments?

thanks for the help
AL
MnSCU/PALS

----------------------
Alan Rykhus
alan.rykhus@Mankato.MSUS.EDU