Well.. I've tried it again.. and again it's failed

Anthony Rumble (anthony@rumble.waratah.id.au)
Thu, 11 Sep 1997 08:43:38 +1000 (EST)

Message-Id: <m0x8vU2-00031CC@jolt.mpx.com.au>
Subject: Well.. I've tried it again.. and again it's failed
To: fastcgi-developers@OpenMarket.com
Date: Thu, 11 Sep 1997 08:43:38 +1000 (EST)
From: anthony@rumble.waratah.id.au (Anthony Rumble)

I tried it before in January.. and it used to fall over
all the time..

I saw a new sfio released which now has proper linux support

So.. I decided to try again..

Unfortunately.. with exactly the same results..

Running sfio 97 release
Perl 5.004_03 with sfio on
apache 1.2.4 with the mod_apache
running the sfio FCGI v0.31

under Linux 2.0.30 running redhat 4.2

Same symptoms.. I have a script that is executed very often
(it's called a jump script.. it's for following click throughs
which is why it has to be fast)

When I run the appclass...
AppClass /home/httpd/html/matilda/jumpto.fcg -processes 3 -initial-env FCGI_MODE=true

It lasts for a little while ok.. then it STOPS.. 
do a ps -lxaw | grep fcg
and it's sitting in the "unix_data_wait" state..

So I try TCP mode.. use

AppClass /home/httpd/html/matilda/jumpto.fcg -processes 3 -initial-env FCGI_MODE=true -port 8000

Same thing.. runs for about a day ok.. then stops..
no longer accepts connections... I can't even telnet to the port

Does ANYONE have ANY idea whatsoever could be the problem here..
Im pulling my hair out trying to make this work.. 
I need something like fastcgi that can do these scripts.. but so
far it's just not reliable enough..

-- 
Anthony Rumble - aka SmilieZ
Mobile 015-955-042 Pager 016-634-997
Interactive Infotainment Systems Pty. Ltd.
PERL CGI HTTP HTML Linux Unix Firewalls Web Servers
Home Page/PGP key http://www.infotainment.com.au/