Re: Assertion Failed?

Stanley Gambarin (stanleyg@cs.bu.edu)
Mon, 22 Sep 1997 16:58:50 -0400 (EDT)

Date: Mon, 22 Sep 1997 16:58:50 -0400 (EDT)
From: Stanley Gambarin <stanleyg@cs.bu.edu>
To: Fabian Thylmann <thylmann@m1.sprynet.com>
Subject: Re: Assertion Failed?
In-Reply-To: <3.0.3.32.19970922210436.00936280@m1.sprynet.com>
Message-Id: <Pine.GSO.3.96.970922165650.12163A-100000@csa>


	You are not using the latest mod_fastcgi module.  This was
a known problem with not casting header to (char *), resulting in
the assertion failure.  This was fixed in the 2.0.x and I believe in
1.4.3 as well, so you really need to upgrade to the newer version
of module (to stop having so many problems).  

						Stanley.

On Mon, 22 Sep 1997, Fabian Thylmann wrote:

> Hello,
> 
> now that it seems I have found the reason why the OS Errors happen (The
> famout SOCONNMAX [or what it was called again] is set to 5), I am getting
> this all the time:
> 
> mod_fastcgi.c:3630: failed assertion `header.version == FCGI_VERSION'
> 
> What does that mean, and how do I fix it?
> 
> Thanks,
> 
> 
>