Re: Assertion Failed?

Fabian Thylmann (thylmann@m1.sprynet.com)
Wed, 24 Sep 1997 04:18:58 +0200

Message-Id: <3.0.3.32.19970924041858.007dc380@m1.sprynet.com>
Date: Wed, 24 Sep 1997 04:18:58 +0200
To: Stanley Gambarin <stanleyg@cs.bu.edu>
From: Fabian Thylmann <thylmann@m1.sprynet.com>
Subject: Re: Assertion Failed?
In-Reply-To: <Pine.GSO.3.96.970922165650.12163A-100000@csa>

At 04:58 PM 9/22/97 -0400, Stanley Gambarin wrote:
>	You are not using the latest mod_fastcgi module.  This was
>a known problem with not casting header to (char *), resulting in
>the assertion failure.  This was fixed in the 2.0.x and I believe in
>1.4.3 as well, so you really need to upgrade to the newer version
>of module (to stop having so many problems).  

I am getting this error with the following configs:

apache 1.2.1
mod_fastcgi 1.4.3 or 2.0.7
fastcgi dev-kit 1.5.1 or 1.5.2 or 2.0b2 or 2.0b2.1

With virtually any combination of those, I get:
mod_fastcgi.c:3839: failed assertion `header.version == FCGI_VERSION'

And, my fastcgi's are slowly dieing.. or rather, locking up..
I know that they are locking up because I can see they are still alive but
they don't do anything.
I could not yet try the debug stuff, because I simply do not have gdb. I
will get this later and check to figure out where it hangs.