Re: fastcgi echo hangs if called via form

Sonya Rikhtverchik (
Thu, 25 Sep 1997 10:20:49 -0400

Message-Id: <>
Subject: Re: fastcgi echo hangs if called via form
Date: Thu, 25 Sep 1997 10:20:49 -0400
From: Sonya Rikhtverchik <>

Message-Id: <>
Date: Tue, 23 Sep 1997 11:27:19 -0700
From: Devin Ben-Hur <>
Organization:, Inc.
X-Mailer: Mozilla 3.0Gold (Win95; I)
MIME-Version: 1.0
To: Kelly Carney <>
Subject: Re: fastcgi echo hangs if called via form
References: <>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Sonya Rikhtverchik wrote:
> From: Kelly Carney <>
> Subject: fastcgi echo hangs if called via form
> Can someone verify this problem.  It's simple to demonstrate
> and it's driving me crazy.
> A link that uses the fastcgi "echo" (Perl or C version) example
> program works fine.  But a FORM action set to call the fastcgi
> echo program will hang.
> My current setup:
>    perl5.004 compiled with sfio
>    fastcgi library 2.01b2.1 (from )
>       cgi-fcgi with Netscape Server 2.0 (also have 3.0)
> 0.31
>    Solaris 5.4 (I also have 5.5.1 available)
> Using fastcgi 1.5.2 cgi-fcgi works fine!

I ran into this problem too using cgi-fcgi with Netscape Commerce Server
& SunOS 4.1.2.  The 2.x version of the fastcgi kit would hang on any
POST (though form GETs worked fine).  Going back to the 1.5x kit worked
fine with POSTs.

> I'd appreciate any ideas on how to debug this problem.  I've been
> using "sudo truss -rall -wall -p pid" to connect to running fastcgi
> processes then look through the system calls for clues.  But first,
> let me know if this is busted for anyone else.

It's busted for me.  I'm not sure about debugging. I'm moving my
site to Solaris+Apache soon so I'll trade this one for a different set
of problems :(

- --
Devin Ben-Hur     <>, Inc.  The Ultimate Game Store
"Dark is the suede that mows like a harvest" -- Martian Ambassador

------- End of Forwarded Message